eOTC Partial Outage

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 01:23 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 08:23 EDT

Investigating

We are currently investigating an issue where some users are unable to connect to eOTC from the Gemini website. All assets remain secure. Further updates to follow.
Posted Jun 12, 2025 - 08:22 EDT
This incident affected: Gemini eOTC.