Solana Staking and Unstaking Delays

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 11:46 EDT

Update

We are currently investigating delays affecting Solana (SOL) staking and unstaking requests. These requests may take longer than expected to process. All customer accounts and funds remain completely secure. Further updates will be shared once available.
Posted Mar 10, 2026 - 01:03 EDT

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 18:01 EST

Investigating

SOL withdrawals and SOL unstaking requests may be delayed and may take longer than expected to complete. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Mar 03, 2026 - 18:00 EST
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).