Stablecoin Withdrawals Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 07, 2026 - 08:59 EDT

Investigating

Customers may be unable to withdraw stablecoins. We are working on a fix and will update as soon as more information is available. All customer accounts and funds remain completely secure.
Posted May 07, 2026 - 08:35 EDT
This incident affected: Crypto Deposits and Withdrawals.