Temporary issue affecting EUR users - Portfolio is not loading

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 02:15 EDT

Investigating

EUR users may experience issues with their Gemini portfolio not loading properly. Please rest assured that all user accounts and funds remain completely secure. We will provide updates as soon as they become available. Thank you for your patience.
Posted Jun 25, 2025 - 22:45 EDT
This incident affected: Gemini ActiveTrader™.